Apple iMac Graphics Firmware Update for ATI HD 2600? Maybe Not.

So Apple releases a firmware update for iMacs with ATI Radeon HD Graphics.

OK, I run Software Updater but it doesn’t register. No biggie, maybe they just haven’t rolled it to the auto-updater yet. I’ll check it out and download directly instead.

The Release Notes are pretty clear:

This update is for iMac computers with an ATI Radeon HD 2600 Pro… graphics card installed,

Yep, that’s me.

running Mac OS X 10.5.2 or later.

Me too.

After this update has been successfully completed, ROM version will be: 113-B2250L-259

Perfect. Mine’s currently 113-B2250F-219, so it looks like I need the update.

Download it, run it, and I get this:

Rats! Well, that explains why Software Updater didn’t find it.

What other criteria (that Apple doesn’t specify) preclude me from needing this? Or is the prerequisite check in the installer broken, and it won’t apply to my system even though I need it?

Whatever the case, I’m not alone in having this problem.

Advertisements

2 thoughts on “Apple iMac Graphics Firmware Update for ATI HD 2600? Maybe Not.

  1. Applies to
    System Requirements
    Mac OS X 10.5.2 or later
    iMac Early 2008

    NOT EARLIER than early 2008

Comments are closed.